Back to overview
Resolved

Physical Server Maintenance

Jun 12, 2026 at 1:00am UTC  –  Jun 12, 2026 at 2:00am UTC
Affected services
tlsservers.com
billing.tlsservers.com

Resolved
Jun 12, 2026 at 2:00am UTC

Maintenance ended

Created
Jun 12, 2026 at 1:00am UTC

Will be replacing shroud on the server to make it cooler.